Related Posts Plugin for WordPress, Blogger...

Tuesday, March 29, 2011

geant4 direct installation for UBUNTU and DEBIAN

Here is the simplest installation method for geant4

Open terminal from Applications --> Accessories --> Terminal and type in:

sudo gedit /etc/apt/sources.list
Now add the following lines at the end of the file and then save it and close.


deb http://lcg-heppkg.web.cern.ch/lcg-heppkg/debian stable hep
deb-src http://lcg-heppkg.web.cern.ch/lcg-heppkg/debian stable hep
Now in the terminal type in:
sudo apt-get install cern-archive-keyring

This will resolve the following problem while updating:

W: GPG error: http://lcg-heppkg.web.cern.ch stable Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY F464E3D84061544D

Now type in:

sudo apt-get update
sudo apt-get install geant4

That's all...

The root directory for geant4 installation is:

/usr/share/geant4

For post-installation settings follow the instructions in the post:



Cheers....
Print Friendly and PDF

9 comments:

  1. I get the following error;


    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    geant4 : Depends: libgeant4-dev but it is not going to be installed
    Depends: libgeant4-plists-dev but it is not going to be installed
    Depends: libg4opengl-dev but it is not going to be installed
    Depends: geant4-examples but it is not going to be installed
    E: Broken packages

    What am I supposed to do?

    ReplyDelete
  2. May I know the version of Ubuntu you are using...

    ReplyDelete
  3. I am using Ubuntu 11.04 natty, I tried to follow the same directions in a friends computer as well, with the same OS. Unfortunately I got the same error.

    ReplyDelete
  4. I could be able to install it on Ubuntu natty 11.04.

    Please try it once again after taking all updates and upgrades.


    sudo apt-get update
    sudo apt-get dist-upgrade

    Then verify whether the above mentioned two lines are added to sources.list file properly or not.

    Then


    sudo apt-get update

    sudo apt-get install cern-archive-keyring

    sudo apt-get install geant4


    Hope it works...

    Please update the further status...

    Cheers,
    SANJEEV

    ReplyDelete
  5. Unfotunately it didn't work, I still get the same error...

    ReplyDelete
  6. ciao

    i whish to know if this issue was solved

    i'm using ubuntu 10.04

    when i try
    sudo apt-get install geant4

    i also get:
    The following packages have unmet dependencies:
    geant4: Depends: libgeant4-dev but it is not going to be installed
    Depends: libgeant4-plists-dev but it is not going to be installed
    Depends: libg4opengl-dev but it is not going to be installed
    Depends: geant4-examples but it is not going to be installed
    E: Broken packages

    ReplyDelete
  7. I have the same problem and I can't find any solution... Does anybody can help us?

    ReplyDelete
  8. NATIONAL INSTITUTE OF DIGITAL EDUCATION established in 2010 with the mission of delivering training to professionals in Computer Training. We offer a wide range of quality computer training.

    All our training courses are taught by professionals in the field, allowing you the chance to learn from experts within their respected industry, which provides you with a quality computer training that will help you take your knowledge and career to new heights. We have different courses to shoot-up the requirement of the general youths of West Bengal. The duration of the courses are segregated in Six Months, One Year & 18 Months. Students are awarded by CERTIFICATE which will accept all over India.
    -----------------------------------------------------------------------------------------------------
    Email: info@nideindia.in / nidedirector@gmail.com

    Website : http://www.nideindia.in , Facebook : https://www.facebook.com/NIDEofficial/

    Twitter : https://twitter.com/nideindia , YouTube : https://www.youtube.com/channel/UCDvV-Fhx9Tz3jDmeZu4EOUw

    Android App : https://play.google.com/store/apps/details?id=com.ntss.nide

    ReplyDelete